Follow

Windows Collector 6.9.X Release Notes

Software Requirements

Supported operating systems

Desktop

  • Windows 7 - 32 and 64 bits - requires OS update (see pre-requisites below)
  • Windows 8 and 8.1 - 32 and 64 bits
  • Windows 10 - 32 and 64 bits

Server

  • Windows Server 2008 R2 - 64 bits - requires OS update (see pre-requisites below)
  • Windows Server 2012 and 2012 R2 - 64 bits

Note that Windows XP, Windows Vista, Windows Server 2003, and Windows Server 2008 are no longer supported.

Pre-requisites

  • The targeted device must be able to communicate via TCP and UDP with the Engine.
  • To install the Collector using their MSI, the Windows installer (msiexec) version 3.0 or higher is required.
  • The installation of the Collector 6.9.x on Windows 7 (32 and 64 bit) and Windows Server 2008 R2 (64 bit) devices requires update Microsoft KB 3033929 to be previously applied.

Nexthink dependency matrix

The latest Engine is always compatible with the latest version of Collector and with all its previous versions. If you want to upgrade to the latest release of the Collector, we encourage you to upgrade your Engines first.

  Engine 6.9 or higher Engine 6.8 Engine 6.7
Engine 6.1 Engine 5.3
Collector 6.9 OK Not OK

Not OK

Not Ok

Not OK

Collector 6.8 OK OK

Not OK

Not OK

Not OK

Collector 6.7

OK

OK

OK

Not OK

Not OK

Collector 6.1

OK

OK

OK

OK - without DirectAccess support

OK - with DirectAccess support in Engine 5.3.6, 5.3.7, and 5.3.8 only

Collector 5.3 OK OK OK OK OK

Version 6.9.2.1

New Features

  • [CLT-2385] - The Collector driver is digitally signed by Microsoft (HLK).
  • [EUF-557] - The Collector displays translated campaigns.

Version 6.9.1.8

New Features

This is a preview version of the Collector that uses a new communication subsystem. It is equivalent in functionality to the 6.9.2.1 version. Please use it for new installations.

  • [CLT-2385] - The Collector driver is digitally signed by Microsoft (HLK).
  • [EUF-557] - The Collector displays translated campaigns.
  • [CLT-2437] - The Collector communicates with Engine in User Mode and not in Kernel Mode.
  • [CLT-2472] - The Advanced panel has been removed from the Control Panel extension of the Collector.

Known restrictions

In the Control Panel extension, the statistics are not populated.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk